Skip to main content
Act-On Software

Minimum Technical System Requirements

In order to ensure the best possible experience, you will want to use one of the following supported browsers when working within Act-On. 

  • Most Recent Version of Firefox
  • Most Recent Version of Chrome
  • Internet Explorer 10/11
  • Microsoft Edge
  • Was this article helpful?